The discussion for naming the function of type
[Either a b] -> ([a],[b]) is not going well. We’ve discussed
partitionEithers and none of them seem acceptable. I’m hoping someone out there can help me.
Do you know category theory? We can phrase this in terms of category theory, and perhaps there is a good name for this function there.
Given a functor F, what would you call a morphism F(a + b) → F(a) × F(b), where + and × are the coproduct and product respectively?